Car won’t start 2004 Oldsmobile Alero - Oldsmobile Forum - Oldsmobile Enthusiasts Forums

Go Back   Oldsmobile Forum - Oldsmobile Enthusiasts Forums > General > New Member Area

LinkBack Thread Tools Search this Thread
Old 08-28-2007, 08:07 PM
Junior Member
Join Date: Aug 2007
Location: United States
Posts: 1

Need sugestions on how to start my car. All I did was changed a Booster for my brakes then my car would not start. I tried boosting it because the battery was down; maybe because of having the door open to long.

I didn't really think I was out of gas but I did put some more in the tank just in case.

I checked all the fuses. I don't know what else to do.

I never had trouble with the car not starting before.
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Alero, won't start jduffy Alero 3 06-09-2010 08:03 PM
98 Intrigue Won’’t Start Captain Bravo General Tech Help 4 02-15-2009 10:23 PM
’’Parasitic’’ drain, intermittent dcarlson12 Eighty-Eight 0 09-16-2008 04:50 PM
1994 Achieva 2.3 Won’’t start jtwink General Tech Help 0 08-20-2008 01:08 PM
I have a 2004 Olds Alero and it won't turn over. The battery is fine.It's a year old and I did try to jump it.Everything power is working...">2004 Alero wont turn over Tramp Alero 0 03-28-2008 07:23 AM

2004, alero, car, engine, forum, olds, oldsmobile, start, starting, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -5. The time now is 06:40 PM.