1998 olds 88 no crank no start? - Oldsmobile Forum - Oldsmobile Enthusiasts Forums

Eighty-Eight Talk about the Oldsmobile Eighty-Eight within...

1998 olds 88 no crank no start?

  #1  
Old 12-04-2018, 05:18 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 3
Default 1998 olds 88 no crank no start?

I recently installed a new engine into my Olds 88 after the old engine overheated and cracked the block. I triple checked everything making sure everything is connected. The battery on it is old but it had enough from charging to crank the old engine, I put in the key, turn the switch, nothing happens. Lights come on and everything but no cranking. After a few tries I noticed the dash lights stopped coming on so I went and saw that one of the ignition switch fuses blew, replaced it, and realized I had a ground wire not going anywhere, so I bolted it to the block as it should be, tried again, no avail. Checked all my connections 2 more times, everything checks out ok. Literally everything works except cranking. No security lights, and I tried both of the starters and they both do nothing. Any help at all? Iím very frustrated Iíve gone through all of this to have something so dumb as this to randomly come up and not work.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
breeze
Alero
0
04-07-2017 10:16 PM
breeze
Alero
0
03-15-2017 09:00 PM
vinny01930
General Tech Help
2
08-09-2008 11:48 PM
vinny01930
General Tech Help
5
01-25-2008 06:29 PM
dlsimon
General Tech Help
0
04-01-2006 05:39 AM


Thread Tools
Search this Thread
Quick Reply: 1998 olds 88 no crank no start?


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.