Ninety-Eight Talk about the Oldsmobile Ninety-Eight within...

Multiple system failure in AC

  #1  
Old 05-25-2019, 12:10 PM
Junior Member
Thread Starter
Join Date: May 2019
Posts: 1
Default Multiple system failure in AC

Hey guy!

I'm going to try to make this as short as possible for you guys.

I bought this '92 98 last year, new engine, rebuilt transmission, new compressor, and "new" Digital AC display a steal for $2k.

A month after I bought it the blower motor quit (of course it did &#128530

I just now got around to working on it, the fuses we're good, the relay was good, and the blower can be hot wired and it works...

So I thought it must be a short somewhere so I rigged it up to be hotwired from a switch I mounted in the dash. (I'm a redneck.... I know)

But Im having a multi point failure.

The vents are stuck on defrost
The compressor clutch is not engaging
And the blower motor is not getting any power (when not hot wired)

Any thoughts as to what would make all these systems fail?

Any help would be appreciated
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
oldparts
Cutlass
1
02-06-2017 07:34 PM
twinge
Intrigue
0
02-04-2014 04:55 PM
PHIL BARTHEL
General Tech Help
0
04-27-2011 09:43 AM
91cutlasssupreme
General Tech Help
0
07-03-2010 09:52 AM
mmurphy83
Cutlass
0
03-31-2010 10:47 PM


Thread Tools
Search this Thread
Quick Reply: Multiple system failure in AC


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.