03 silhouette overheating - Oldsmobile Forum - Oldsmobile Enthusiasts Forums

Silhouette Talk about the Oldsmobile Silhouette within...

03 silhouette overheating

  #1  
Old 01-10-2019, 06:21 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 1
Default 03 silhouette overheating

Sometimes I have heat & sometimes I don't. Also with it overheating. I can drive a total of 5 miles till I loose heat & starts to overheat. I have replaced the thermastat & got a new radiator cap. Done a do it yourself flushing system. With still these problems. I am thinking my water pump is not having enough power or my temp control module is out. I'm almost certain its not a blown gasket. I'm not loosing any fluid, oil looks good. If anyone has any other ideas or tips to try please let me know.
 
  #2  
Old 01-11-2019, 10:29 AM
azu
azu is offline
Junior Member
Join Date: Apr 2009
Location: Darby, PA
Posts: 14
Default

Could be water pump and/or clogged radiator and/or clogged heater core.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
YORKSHIREMAN
General Tech Help
0
11-08-2008 08:20 PM
crustydclown
Alero
3
03-15-2007 07:52 PM
lochi
Intrigue
1
03-02-2007 01:23 AM
Steve2
General Tech Help
3
01-30-2007 11:51 PM
Steve2
New Member Area
3
01-15-2007 12:56 PM


Thread Tools
Search this Thread
Quick Reply: 03 silhouette overheating


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.