Toronado Talk about the Oldsmobile Toronado within...

1966 Toronado

  #1  
Old 09-17-2013, 08:02 PM
Junior Member
Thread Starter
Join Date: Sep 2013
Posts: 1
Default 1966 Toronado

I have a 1966 Toronado. I have rebuilt the carb and the car idles well and sounds great when it revs up, but when I put it into drive the car dies out. Kind of like when you turn down the idle to low. I have put a new vacuum line from the master cylinder to the top of the intake manifold. This appeared to help some, but the car still chugs and dies out in drive. Someone at some point has put a jegs power booster and dual master cylinder on here. They also put a performance adjustable proportioning valve with prop block and di; and they replaced the front drums with rotars. I was wondering if this system could be messing up the vacuum. One other thing. The car had bad gas with a little rust in the tank. I drained it out and used seafoam and put about 10 gallons of premium gas in. I did not change the fuel filter. I am not even sure where it is. I would think if it was a gas problem it would not run good in idle. Anyways. Any information would be great. This car is starting to give me a headache.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
elgemcdlf
General Tech Help
3
12-20-2011 08:46 AM
Paulie
General Tech Help
0
10-27-2011 09:17 AM
dennis gibson
Restoration
1
08-06-2007 11:29 AM
velvetgreen
Eighty-Eight
0
07-26-2007 07:30 PM
gwgarage
PRIVATE For Sale / Trade Classifieds
0
08-02-2006 07:50 PM


Thread Tools
Search this Thread
Quick Reply: 1966 Toronado


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.