Alero Talk about the Oldsmobile Alero within...

Hesitating after replacing fuel pump and filter

  #1  
Old 05-10-2011, 03:29 PM
Junior Member
Thread Starter
Join Date: May 2011
Posts: 2
Default Hesitating after replacing fuel pump and filter

Hello,

I have a 2002 Alero GLS 6 cyl automatic. It was starting rough, and finally wouldn't start at all. I replaced the fuel filter, and still nothing, so I just finished replacing the fuel pump and it fires up just fine.

When driving however, it only will accelerate under just a little pedal, or wide open. In between in hesitates badly. It also will not shift out of first, ~4000 RPMS to get to 30 mph. If I let off the gas completely it will shift, but the hesitation problem remains.

Any ideas???? Thanks in advance!!
 
  #2  
Old 05-10-2011, 05:42 PM
Junior Member
Thread Starter
Join Date: May 2011
Posts: 2
Default

Update-must have had to clear some bad gas or something, runs smooth now. BUT still will not shift to the next gear when wide open on the pedal???
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
henryandrade1977
Cutlass
1
10-02-2011 11:52 AM
oldsintrigue02
General Tech Help
2
09-18-2011 05:10 PM
gwmats
General Tech Help
0
08-22-2010 06:33 PM
mbeals
Alero
31
11-25-2009 07:36 PM
ramsey1chris
Aurora
1
12-22-2005 06:28 PM


Thread Tools
Search this Thread
Quick Reply: Hesitating after replacing fuel pump and filter


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.